Could not Load SWT Library Eclipse Error

Eclipse merupakan salah satu IDE favorit bagi programmer.

Selain nyaman digunakan, Eclipse memiliki banyak plugin untuk membuat ataupun mengembangkan aplikasi tertentu.

Eclipse tersedia di berbagai platform, termasuk Linux dan Windows.

Beberapa saat yang lalu ketika saya menginstall Eclipse di Linux, tepatnya distro Ubuntu 12.04 Precise Pangolin, saya menemui masalah yaitu terdapat error ketika membuka Eclipse pertama kali.

Saya merasa bingung, sebab biasanya ketika saya menginstall Eclipse di Ubuntu, tidak pernah mengalami error saat membuka Eclipse.

Error tersebut menyebabkan Eclipse menjadi tidak bisa di buka.

Could not Load SWT Library Eclipse Error

Setelah browsing kesana kemari, saya akhirnya menemukan solusi dari permasalahan tersebut.

Hal pertama yang harus dipahami adalah, kita haru mengetahui penyebab error tersebut, caranya adalah dengan membuka log file dari Eclipse.

Berikut ini adalah log dari Eclipse ketika mengalami error saat dibuka pertama kali.

!SESSION 2013-06-06 09:44:07.857 ———————————————–
eclipse.buildId=I20110613-1736
java.version=1.6.0_45
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86

!ENTRY org.eclipse.osgi 4 0 2013-06-06 09:44:09.931
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
no swt-gtk-3740 in java.library.path
no swt-gtk in java.library.path
Can’t load library: /home/azuharu/.swt/lib/linux/x86/libswt-gtk-3740.so
Can’t load library: /home/azuharu/.swt/lib/linux/x86/libswt-gtk.so

at org.eclipse.swt.internal.Library.loadLibrary(Library.java:285)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:194)
at org.eclipse.swt.internal.C.<clinit>(C.java:21)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)
at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:695)
at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:153)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:95)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)

Untuk mengatasi error tersebut, kita dapat menambahkan sebuah baris yang menunjukkan letak libswt-gtk-3740.so dan libswt-gtk.so sehingga Eclipse dapat dibuka dengan baik.

Perhatikan baris di bawah:

Can’t load library: /home/azuharu/.swt/lib/linux/x86/libswt-gtk-3740.so
Can’t load library: /home/azuharu/.swt/lib/linux/x86/libswt-gtk.so

Yang kita lakukan cukup menambahkan semacam path yang merujuk ke library bersangkutan, salah satu caranya adalah dengan menambahkann di eclipse.ini baris berikut:

echo “-Djava.library.path=/usr/lib/jni”

Semoga bermanfaat.

Leave a Reply

Your email address will not be published. Required fields are marked *